o Added initial SCTP port scanning support to Nmap. SCTP is

a layer 4 protocol used mostly for telephony related applications.
  This brings the following new features:
  o SCTP INIT chunk port scan (-sY): open ports return an INIT-ACK
    chunk, closed ones an ABORT chunk.  This is the SCTP equivalent
    of a TCP SYN stealth scan.
  o SCTP COOKIE-ECHO chunk port scan (-sZ): open ports are silent,
    closed ports return an ABORT chunk.
  o SCTP INIT chunk ping probes (-PY): host discovery using SCTP
    INIT chunk packets.
  o SCTP-specific IP protocol scan (-sO -p sctp).
  o SCTP-specific traceroute support (--traceroute).
  o The ability to use the deprecated Adler32 algorithm as specified
    in RFC 2960 instead of CRC32C from RFC 4960 (--adler32).
  o 42 well-known SCTP ports were added to the nmap-services file.
  Part of the work on SCTP support was kindly sponsored by
  Compass Security AG, Switzerland.  [Daniel Roethlisberger]
This commit is contained in:
daniel 2009-06-03 23:15:45 +00:00
parent 99c4008c03
commit 50830f7488
36 changed files with 1333 additions and 152 deletions

View file

@ -445,9 +445,12 @@ Index: libdnet-stripped/src/intf-win32.c
} else
return (-1);
Added eth_get_pcap_devname() that matches up a dnet name to its pcap
equivalent by matching hardwar addresses. It's similar to the code
used in eth_open()
o Added eth_get_pcap_devname() that matches up a dnet name to its pcap
equivalent by matching hardwar addresses. It's similar to the code
used in eth_open()
o Added SCTP support. Not including patches since the SCTP changes
will be included in the next libdnet release. [Daniel Roethlisberger]
o Handle the case of sa_len == 0 (meaning 0.0.0.0) in addr_stob.
Index: src/addr.c

View file

@ -19,6 +19,7 @@
#include <dnet/icmp.h>
#include <dnet/tcp.h>
#include <dnet/udp.h>
#include <dnet/sctp.h>
#include <dnet/intf.h>
#include <dnet/route.h>

View file

@ -5,4 +5,4 @@ include $(top_srcdir)/Makefile.am.common
dnetincludedir = $(includedir)/dnet
dnetinclude_HEADERS = addr.h arp.h blob.h eth.h fw.h icmp.h intf.h ip.h \
ip6.h os.h rand.h route.h tcp.h tun.h udp.h
ip6.h os.h rand.h route.h tcp.h tun.h udp.h sctp.h

View file

@ -0,0 +1,168 @@
/*
* sctp.h
*
* Stream Control Transmission Protocol (RFC 4960).
*
* Copyright (c) 2008-2009 Daniel Roethlisberger <daniel@roe.ch>
*
* $Id$
*/
#ifndef DNET_SCTP_H
#define DNET_SCTP_H
#define SCTP_HDR_LEN 12
struct sctp_hdr {
uint16_t sh_sport; /* source port */
uint16_t sh_dport; /* destination port */
uint32_t sh_vtag; /* sctp verification tag */
uint32_t sh_sum; /* sctp checksum */
};
#define SCTP_PORT_MAX 65535
#define sctp_pack_hdr(hdr, sport, dport, vtag) do { \
struct sctp_hdr *sctp_pack_p = (struct sctp_hdr *)(hdr); \
sctp_pack_p->sh_sport = htons(sport); \
sctp_pack_p->sh_dport = htons(dport); \
sctp_pack_p->sh_vtag = htonl(vtag); \
} while (0)
struct sctp_chunkhdr {
uint8_t sch_type; /* chunk type */
uint8_t sch_flags; /* chunk flags */
uint16_t sch_length; /* chunk length */
};
/* chunk types */
#define SCTP_DATA 0x00
#define SCTP_INIT 0x01
#define SCTP_INIT_ACK 0x02
#define SCTP_SACK 0x03
#define SCTP_HEARTBEAT 0x04
#define SCTP_HEARTBEAT_ACK 0x05
#define SCTP_ABORT 0x06
#define SCTP_SHUTDOWN 0x07
#define SCTP_SHUTDOWN_ACK 0x08
#define SCTP_ERROR 0x09
#define SCTP_COOKIE_ECHO 0x0a
#define SCTP_COOKIE_ACK 0x0b
#define SCTP_ECNE 0x0c
#define SCTP_CWR 0x0d
#define SCTP_SHUTDOWN_COMPLETE 0x0e
#define SCTP_AUTH 0x0f /* RFC 4895 */
#define SCTP_ASCONF_ACK 0x80 /* RFC 5061 */
#define SCTP_PKTDROP 0x81 /* draft-stewart-sctp-pktdrprep-08 */
#define SCTP_PAD 0x84 /* RFC 4820 */
#define SCTP_FORWARD_TSN 0xc0 /* RFC 3758 */
#define SCTP_ASCONF 0xc1 /* RFC 5061 */
/* chunk types bitmask flags */
#define SCTP_TYPEFLAG_REPORT 1
#define SCTP_TYPEFLAG_SKIP 2
#define sctp_pack_chunkhdr(hdr, type, flags, length) do { \
struct sctp_chunkhdr *sctp_pack_chp = (struct sctp_chunkhdr *)(hdr);\
sctp_pack_chp->sch_type = type; \
sctp_pack_chp->sch_flags = flags; \
sctp_pack_chp->sch_length = htons(length); \
} while (0)
/*
* INIT chunk
*/
struct sctp_chunkhdr_init {
struct sctp_chunkhdr chunkhdr;
uint32_t schi_itag; /* Initiate Tag */
uint32_t schi_arwnd; /* Advertised Receiver Window Credit */
uint16_t schi_nos; /* Number of Outbound Streams */
uint16_t schi_nis; /* Number of Inbound Streams */
uint32_t schi_itsn; /* Initial TSN */
};
#define sctp_pack_chunkhdr_init(hdr, type, flags, length, itag, \
arwnd, nos, nis, itsn) do { \
struct sctp_chunkhdr_init *sctp_pack_chip = \
(struct sctp_chunkhdr_init *)(hdr); \
sctp_pack_chunkhdr(sctp_pack_chip, type, flags, length); \
sctp_pack_chip->schi_itag = htonl(itag); \
sctp_pack_chip->schi_arwnd = htonl(arwnd); \
sctp_pack_chip->schi_nos = htons(nos); \
sctp_pack_chip->schi_nis = htons(nis); \
sctp_pack_chip->schi_itsn = htonl(itsn); \
} while (0)
/*
* INIT ACK chunk
*/
struct sctp_chunkhdr_init_ack {
struct sctp_chunkhdr chunkhdr;
uint32_t schia_itag; /* Initiate Tag */
uint32_t schia_arwnd; /* Advertised Receiver Window Credit */
uint16_t schia_nos; /* Number of Outbound Streams */
uint16_t schia_nis; /* Number of Inbound Streams */
uint32_t schia_itsn; /* Initial TSN */
};
#define sctp_pack_chunkhdr_init_ack(hdr, type, flags, length, itag, \
arwnd, nos, nis, itsn) do { \
struct sctp_chunkhdr_init_ack *sctp_pack_chip = \
(struct sctp_chunkhdr_init_ack *)(hdr); \
sctp_pack_chunkhdr(sctp_pack_chip, type, flags, length); \
sctp_pack_chip->schia_itag = htonl(itag); \
sctp_pack_chip->schia_arwnd = htonl(arwnd); \
sctp_pack_chip->schia_nos = htons(nos); \
sctp_pack_chip->schia_nis = htons(nis); \
sctp_pack_chip->schia_itsn = htonl(itsn); \
} while (0)
/*
* ABORT chunk
*/
struct sctp_chunkhdr_abort {
struct sctp_chunkhdr chunkhdr;
/* empty */
};
#define sctp_pack_chunkhdr_abort(hdr, type, flags, length) do { \
struct sctp_chunkhdr_abort *sctp_pack_chip = \
(struct sctp_chunkhdr_abort *)(hdr); \
sctp_pack_chunkhdr(sctp_pack_chip, type, flags, length); \
} while (0)
/*
* SHUTDOWN ACK chunk
*/
struct sctp_chunkhdr_shutdown_ack {
struct sctp_chunkhdr chunkhdr;
/* empty */
};
#define sctp_pack_chunkhdr_shutdown_ack(hdr, type, flags, length) do { \
struct sctp_chunkhdr_shutdown_ack *sctp_pack_chip = \
(struct sctp_chunkhdr_shutdown_ack *)(hdr); \
sctp_pack_chunkhdr(sctp_pack_chip, type, flags, length); \
} while (0)
/*
* COOKIE ECHO chunk
*/
struct sctp_chunkhdr_cookie_echo {
struct sctp_chunkhdr chunkhdr;
/* empty */
};
#define sctp_pack_chunkhdr_cookie_echo(hdr, type, flags, length) do { \
struct sctp_chunkhdr_cookie_echo *sctp_pack_chip = \
(struct sctp_chunkhdr_cookie_echo *)(hdr); \
sctp_pack_chunkhdr(sctp_pack_chip, type, flags, length); \
} while (0)
#endif /* DNET_SCTP_H */

View file

@ -270,6 +270,10 @@
RelativePath=".\include\dnet\udp.h"
>
</File>
<File
RelativePath=".\include\dnet\sctp.h"
>
</File>
</Filter>
<Filter
Name="Resource Files"

View file

@ -0,0 +1,83 @@
/*
* crc32ct.h
*
* Public domain.
*
* $Id$
*/
#ifndef CRC32CT_H
#define CRC32CT_H
#define CRC32C_POLY 0x1EDC6F41
#define CRC32C(c,d) (c=(c>>8)^crc_c[(c^(d))&0xFF])
static unsigned long crc_c[256] = {
0x00000000L, 0xF26B8303L, 0xE13B70F7L, 0x1350F3F4L,
0xC79A971FL, 0x35F1141CL, 0x26A1E7E8L, 0xD4CA64EBL,
0x8AD958CFL, 0x78B2DBCCL, 0x6BE22838L, 0x9989AB3BL,
0x4D43CFD0L, 0xBF284CD3L, 0xAC78BF27L, 0x5E133C24L,
0x105EC76FL, 0xE235446CL, 0xF165B798L, 0x030E349BL,
0xD7C45070L, 0x25AFD373L, 0x36FF2087L, 0xC494A384L,
0x9A879FA0L, 0x68EC1CA3L, 0x7BBCEF57L, 0x89D76C54L,
0x5D1D08BFL, 0xAF768BBCL, 0xBC267848L, 0x4E4DFB4BL,
0x20BD8EDEL, 0xD2D60DDDL, 0xC186FE29L, 0x33ED7D2AL,
0xE72719C1L, 0x154C9AC2L, 0x061C6936L, 0xF477EA35L,
0xAA64D611L, 0x580F5512L, 0x4B5FA6E6L, 0xB93425E5L,
0x6DFE410EL, 0x9F95C20DL, 0x8CC531F9L, 0x7EAEB2FAL,
0x30E349B1L, 0xC288CAB2L, 0xD1D83946L, 0x23B3BA45L,
0xF779DEAEL, 0x05125DADL, 0x1642AE59L, 0xE4292D5AL,
0xBA3A117EL, 0x4851927DL, 0x5B016189L, 0xA96AE28AL,
0x7DA08661L, 0x8FCB0562L, 0x9C9BF696L, 0x6EF07595L,
0x417B1DBCL, 0xB3109EBFL, 0xA0406D4BL, 0x522BEE48L,
0x86E18AA3L, 0x748A09A0L, 0x67DAFA54L, 0x95B17957L,
0xCBA24573L, 0x39C9C670L, 0x2A993584L, 0xD8F2B687L,
0x0C38D26CL, 0xFE53516FL, 0xED03A29BL, 0x1F682198L,
0x5125DAD3L, 0xA34E59D0L, 0xB01EAA24L, 0x42752927L,
0x96BF4DCCL, 0x64D4CECFL, 0x77843D3BL, 0x85EFBE38L,
0xDBFC821CL, 0x2997011FL, 0x3AC7F2EBL, 0xC8AC71E8L,
0x1C661503L, 0xEE0D9600L, 0xFD5D65F4L, 0x0F36E6F7L,
0x61C69362L, 0x93AD1061L, 0x80FDE395L, 0x72966096L,
0xA65C047DL, 0x5437877EL, 0x4767748AL, 0xB50CF789L,
0xEB1FCBADL, 0x197448AEL, 0x0A24BB5AL, 0xF84F3859L,
0x2C855CB2L, 0xDEEEDFB1L, 0xCDBE2C45L, 0x3FD5AF46L,
0x7198540DL, 0x83F3D70EL, 0x90A324FAL, 0x62C8A7F9L,
0xB602C312L, 0x44694011L, 0x5739B3E5L, 0xA55230E6L,
0xFB410CC2L, 0x092A8FC1L, 0x1A7A7C35L, 0xE811FF36L,
0x3CDB9BDDL, 0xCEB018DEL, 0xDDE0EB2AL, 0x2F8B6829L,
0x82F63B78L, 0x709DB87BL, 0x63CD4B8FL, 0x91A6C88CL,
0x456CAC67L, 0xB7072F64L, 0xA457DC90L, 0x563C5F93L,
0x082F63B7L, 0xFA44E0B4L, 0xE9141340L, 0x1B7F9043L,
0xCFB5F4A8L, 0x3DDE77ABL, 0x2E8E845FL, 0xDCE5075CL,
0x92A8FC17L, 0x60C37F14L, 0x73938CE0L, 0x81F80FE3L,
0x55326B08L, 0xA759E80BL, 0xB4091BFFL, 0x466298FCL,
0x1871A4D8L, 0xEA1A27DBL, 0xF94AD42FL, 0x0B21572CL,
0xDFEB33C7L, 0x2D80B0C4L, 0x3ED04330L, 0xCCBBC033L,
0xA24BB5A6L, 0x502036A5L, 0x4370C551L, 0xB11B4652L,
0x65D122B9L, 0x97BAA1BAL, 0x84EA524EL, 0x7681D14DL,
0x2892ED69L, 0xDAF96E6AL, 0xC9A99D9EL, 0x3BC21E9DL,
0xEF087A76L, 0x1D63F975L, 0x0E330A81L, 0xFC588982L,
0xB21572C9L, 0x407EF1CAL, 0x532E023EL, 0xA145813DL,
0x758FE5D6L, 0x87E466D5L, 0x94B49521L, 0x66DF1622L,
0x38CC2A06L, 0xCAA7A905L, 0xD9F75AF1L, 0x2B9CD9F2L,
0xFF56BD19L, 0x0D3D3E1AL, 0x1E6DCDEEL, 0xEC064EEDL,
0xC38D26C4L, 0x31E6A5C7L, 0x22B65633L, 0xD0DDD530L,
0x0417B1DBL, 0xF67C32D8L, 0xE52CC12CL, 0x1747422FL,
0x49547E0BL, 0xBB3FFD08L, 0xA86F0EFCL, 0x5A048DFFL,
0x8ECEE914L, 0x7CA56A17L, 0x6FF599E3L, 0x9D9E1AE0L,
0xD3D3E1ABL, 0x21B862A8L, 0x32E8915CL, 0xC083125FL,
0x144976B4L, 0xE622F5B7L, 0xF5720643L, 0x07198540L,
0x590AB964L, 0xAB613A67L, 0xB831C993L, 0x4A5A4A90L,
0x9E902E7BL, 0x6CFBAD78L, 0x7FAB5E8CL, 0x8DC0DD8FL,
0xE330A81AL, 0x115B2B19L, 0x020BD8EDL, 0xF0605BEEL,
0x24AA3F05L, 0xD6C1BC06L, 0xC5914FF2L, 0x37FACCF1L,
0x69E9F0D5L, 0x9B8273D6L, 0x88D28022L, 0x7AB90321L,
0xAE7367CAL, 0x5C18E4C9L, 0x4F48173DL, 0xBD23943EL,
0xF36E6F75L, 0x0105EC76L, 0x12551F82L, 0xE03E9C81L,
0x34F4F86AL, 0xC69F7B69L, 0xD5CF889DL, 0x27A40B9EL,
0x79B737BAL, 0x8BDCB4B9L, 0x988C474DL, 0x6AE7C44EL,
0xBE2DA0A5L, 0x4C4623A6L, 0x5F16D052L, 0xAD7D5351L,
};
#endif /* CRC32CT_H */

View file

@ -17,6 +17,30 @@
#include <string.h>
#include "dnet.h"
#include "crc32ct.h"
/* CRC-32C (Castagnoli). Public domain. */
static unsigned long
_crc32c(unsigned char *buf, int len)
{
int i;
unsigned long crc32 = ~0L;
unsigned long result;
unsigned char byte0, byte1, byte2, byte3;
for (i = 0; i < len; i++) {
CRC32C(crc32, buf[i]);
}
result = ~crc32;
byte0 = result & 0xff;
byte1 = (result >> 8) & 0xff;
byte2 = (result >> 16) & 0xff;
byte3 = (result >> 24) & 0xff;
crc32 = ((byte0 << 24) | (byte1 << 16) | (byte2 << 8) | byte3);
return crc32;
}
ssize_t
ip_add_option(void *buf, size_t len, int proto,
@ -123,6 +147,13 @@ ip_checksum(void *buf, size_t len)
if (!udp->uh_sum)
udp->uh_sum = 0xffff; /* RFC 768 */
}
} else if (ip->ip_p == IP_PROTO_SCTP) {
struct sctp_hdr *sctp = (struct sctp_hdr *)((u_char *)ip + hl);
if (len >= SCTP_HDR_LEN) {
sctp->sh_sum = 0;
sctp->sh_sum = htonl(_crc32c((u_char *)sctp, len));
}
} else if (ip->ip_p == IP_PROTO_ICMP || ip->ip_p == IP_PROTO_IGMP) {
struct icmp_hdr *icmp = (struct icmp_hdr *)((u_char *)ip + hl);